Hace tu cajita pirata y compartí todo en cualquier lado #PirateBox

https://i2.wp.com/www.acercadelaeducacion.com.ar/wp-content/uploads/2012/11/wpid-piratebox-logo1.png?resize=226%2C199 La caja pirata es un dispositivo que te permite crear una red wifi por la cual es posible intercambiar archivos y chatear sin que estas actividades sean monitoreadas ni registradas. Según su autor

Inspirado por la radio pirata y los movimientos de cultura libre, PirateBox es un dispositivo móvil autónomo de colaboración e intercambio de archivos. PirateBox utiliza Software Libre y software de código abierto (FLOSS) para crear redes inalámbricas móviles de intercambio de archivos donde los usuarios pueden compartir anónimamente imágenes, vídeo, audio, documentos y otros contenidos digitales.

PirateBox está diseñado para ser nofensivo y seguro. No son necesarios inicios de sesión y no se registra los datos de usuario . El sistema – intencionalmente – no esta conectado a Internet con el fin de evitar el seguimiento y preservar la privacidad del usuario.

PirateBox fue creado por David Darts y está registrada bajo una Licencia Arte Libre (2011). Para obtener más información sobre el proyecto o para saber cómo crear su propio sistema PirateBox, por favor visite http://wiki.daviddarts.com/piratebox

Entonces, podes hacerla con tu computadora conectada aun router, con tu teléfono o como hice yo, con un Router 3g de $160 y 15 minutos de hacking

Cosas que necesitarán

  1. TP-Link MR3020
  2. Memoria USB Flash (con formato FAT32 con una sola partición)
  3. Cable Ethernet (viene con el TP-Link)
  4. 5V/USB batería (Viene con el TP-Link )
  5. Una computadora para conectarte al TP-LINK

Pre-intalación

El siguiente tutorial fue creado en un Linux con Arch Sin embargo, estas instrucciones también funcionará para Mac o Windows (requiere PuTTY ).

  1. Primero, descarguen una copia personalizada de OpenWrt para el MR3020 (modificado por Matthias Strubel para incluir a todos los módulos del kernel necesarios).
  2. Ajusten el interruptor situado junto al puerto LAN / WAN a modo WISP
  3. Apaguen la placa de red de su portátil (en OSX, haga clic en el icono de wifi y seleccione “Activar Wi-Fi Off”)
  4. Conecte el router a través de cable ethernet al ordenador y abra un explorador web para http://192.168.0.254 (para el MR3020)
  5. Introduzca el nombre de usuario y contraseña por defecto (admin y admin)
  6. Vaya a Herramientas del sistema> Actualización de Firmware y seleccione el firmware OpenWRT
  7. Después de la actualización, el sistema se reiniciará (desconecten y reconecten el cable de red)
  8. Hagan Telnet al dispositivo.:
telnet 192.168.1.1
  1. Utilice el comando passwd para configurar la contraseña de inicio de sesión – esto permitirá SSH.:
passwd

10 Edite el archivo de red con vi (. vi chuleta ):

NOTA: Las siguientes instrucciones asumen su router gateway (home router) Dirección IP es 192.168.2.1. Si su puerta de enlace (gateway) es diferente, tendrán que modificar su archivo de red en consecuencia. Tengan en cuenta que su OpenWrt (PirateBox) router no debe tener la misma dirección que el router gateway aunque tendrá que estar en la misma subred para acceder y descargar archivos desde Internet.

vi /etc/config/network

El archivo modificado debe ser similar a esto:

config interface 'loopback'                                                               
        option ifname 'lo'                                                                
        option proto 'static'                                                             
        option ipaddr '127.0.0.1'                                                         
        option netmask '255.0.0.0'                                                        

config interface 'lan'                                                                    
        option ifname 'eth0'                                                              
        option type 'bridge'                                                              
        option proto 'static'                                                             
        option ipaddr '192.168.2.111'                                                       
        option netmask '255.255.255.0'                                                    
        option gateway '192.168.2.1'                                                     
        list dns '192.168.2.1'                                                           
        list dns '8.8.8.8'
  1. Apaguen el router.
  2. Activen la conexión inalámbrica de su portátil (para OSX, haga clic en el icono de wifi y seleccione “Activar Wi-Fi On”)
  3. Conecten el MR3020 a su puerta de enlace -gateway – (por ejemplo, el router de la red de origen) con un cable Ethernet y el conector de alimentación. Esperen un par de minutos hasta que arranca el router. Con el ordenador conectado a la red doméstica, traten de intentar conectarse con ssh al router (Nota: utilizar el “ipaddr” asignado en el paso 9):
ssh root@192.168.2.111
  1. Pingueen a google para garantizar que la configuracion del firewall sea correcta:
ping google.com
  1. Para crear el soporte USB en el OpenWrt instalar y habilitar los siguientes paquetes. (Nota: Este paso no es necesario si se utiliza la imagen personalizada de OpenWrt desde el paso 1):
opkg update
opkg install kmod-usb-uhci
usbcore ## insmod puede devolver el mensaje: insmod: no se puede insertar 'usbcore': File exists
insmod uhci
opkg install kmod-usb-ohci ## puede devolver el mensaje: instalado en la raíz está actualizado.
insmod usb-ohci

Instalación de PirateBox – La Cajita Pirata –

A continuación, tendrá que instalar PirateBox en el router.

  1. Conecten su unidad USB (formateado a FAT32 con una sola partición) en el puerto USB.
  2. Instalen el paquete mkPirateBox usando los siguientes comandos.
cd /tmp
wget http://piratebox.aod-rpg.de/piratebox_0.5.1_all.ipk
 opkg update && opkg install piratebox*
  1. Opcional: Instale la sala de chat Kareha :
/Opt/piratebox/bin/install_piratebox.sh  /opt/piratebox/conf/piratebox.conf imageboard

A continuación, editen la imagen Kareha config cambiando en archivo con el nombre de usuario admin y la contraseña (ADMIN_PASS y secreto):

vi /opt/piratebox/www/board/config.pl

  1. Una vez que la instalación se haya completado, desenchufen el cable ethernet y desconecte la alimentación durante al menos 10 segundos.

. 5 Reinicie el equipo y unanse a lared “PirateBox – Share freely” de la red. Abran cualquier página web y deben ser redirigido al menú PirateBox.

  1. Comience a compartir archivos y chatear!

La próxima entrega les muestro como cambiar algunas cosas, como por ejemplo el nombre de red y las páginas en castellano

Así se ve la página a la cual te conectás.

https://i0.wp.com/www.acercadelaeducacion.com.ar/wp-content/uploads/2012/11/wpid-PirateBoxSendafile1.png

 

Agregar #Systemd a #Arch linux

Hoy fue un día privilegiadamente técnico de ahí que haya aprendido cosas que a la mayoría de los mortales… pues bien poco les importa. Pero para a quienes si nos gustan los desafíos técnicos, bueno, no hay mejor problema que aquel que te deja tu máquina con un prompt preguntándote el login y a vos preguntándote donde diablos está tu gestor de ventanas.

Agregar #Systemd a #Arch linux

En pocas palabras esto es lo que hice (en orden inverso)

En muchas palabras: primero tuve que entender que era lo que pasaba. Recurrí como siempre a la pagina de #Arch

Obviamente fuí a la wiki y luego de mucha lectura hice esto y comenté en el /etcrc.conf las configurciones nuevas. Después esto agregando unaruta al menu.lst de /boot/grub (init=/usr/lib/systemd/systemd)

 

# (0) Arch Linux
title  Arch Linux
root   (hd0,1)
kernel /boot/vmlinuz-linux root=/dev/sda2 init=/usr/lib/systemd/systemd ro
initrd /boot/initramfs-linux.img


y luego comenté la linea en /etc/inittab que arrancaba el GDM

#x:5:respawn:/usr/sbin/gdm -nodaemon

luego agregue el inicio de GDM via systemctl

systemctl enable gdm

Eso es todo amigos y amigas

 

 

Software libre para Bibliotecas #Meran | Cómo extraer páginas de PDF | Más Inkscape

Software Libre para Bibliotecas | Meran

Meran es el sucesor de Koha-UNLP y ya es un sistema que trabaja bajo la filosofía de software libre.

A diferencia de Koha-UNLP que estaba basado en la versión 2.0 de
Koha.org, Meran es un desarrollo nuevo, pensado y creado íntegramente en el ámbito de la UNLP.

Mantiene las funcionalidades de un sistema de gestión, tal como lo presentaba Koha-UNLP y además incorpora prestaciones con una fuerte orientación al usuario mediante el uso de servicios de la Web 2.0 para compartir recursos, comentar, valorar bibliografía y difundir contenidos mediante la interacción con las redes sociales.

La nueva url es http://www.meran.unlp.edu.ar
<http://www.meran.unlp.edu.ar/

Allí hay un instalador automatizado disponible para Debian 6.0 y derivados para arquitecturas de 32 y 64 bits. Como siempre el usuario puede realizar la instalación manual de todas las dependencias.

Meran – Inicio.

Cómo extraer páginas de PDF

Abrimos una terminal y

# primero Instalar psutils y pdf2ps
 pdftops documento.pdf - | psselect -p11-14 | ps2pdf - file-p11-14.pdf

 

via | https://sites.google.com/a/ubuntu.org.uy/www-ubuntu-org-uy-salto/conoce-tu-ancho-de-banda-desde-co

Sencillo tuto para hacer caritas con inkscape

vía | http://2dgameartforprogrammers.blogspot.com.ar/2011/10/lets-get-started-with-circles.html

 

Turtle Confusion en castellano, para que los pibes aprendan a programar

 

Este año retomé con entusiasmo el uso de logo para iniciar a los chicos y chicas en la resolución de problemas a partir de problemas de programación, para eso usamos la actividad de sugar Turtle confusion que está basado en un libro de Barry Newell que se pueden descargar de la web… Pero está en inglés.

Ésta es una traducción al Español del libro “Turtle Confusion” de Barry Newell realizada por Melina Lucía Coronel y revisada y editada por Manuel Kaufmann.

Es gracias a estos esfuerzos que una comunidad crece y se estabiliza en torno a objetivos comunes. Felicitaciones a Manuel Melinda y todos los que colaboraron para que este material esté accesible a todos los docentes de habla hispana.
[1] http://turtle-confusion-spanish-version.readthedocs.org
[2] https://github.com/downloads/humitos/turtle-confusion-es/la-confusion-de-la-tortuga.pdf